Using GALMod on Windows 2008/IIS7

Jun 15, 2009 at 3:30 PM

Hi,

does anyone have experience using this with IIS7? The deployment instructions are for IIS6. I get the following error when using on IIS7:

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
   wpMain.Page_Load(Object sender, EventArgs e) +137
   System.Web.UI.Control.OnLoad(EventArgs e) +132
   System.Web.UI.Control.LoadRecursive() +65
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2603

<font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">

Version Information: Microsoft .NET Framework Version:2.0.50727.1434; ASP.NET Version:2.0.50727.1434

</font>

 

Coordinator
Jun 17, 2009 at 9:58 PM

Hello Howreya,

I've tested it on both IIS 6 and 7 and it works fine in either cases. I hope you are installing it using right Framework version i.e. 2.0 and your asp.net 2 is registered correctly as discussed in document. Additionally you can download the code debug if required.

Please let me know if this helps and even if you remain stuck with the issue.

Cheers,

Sohaib Ahmad

Jul 6, 2009 at 4:22 PM

Hi All,

I seem to get the same error as howerya and don't know how to resolve it.

Regards,

SXS100

Coordinator
Jul 6, 2009 at 5:45 PM

I've looked into the issue. Please refer to newly deployed stable version GALMOD2. Issue is fixed and works perfectly now.

Coordinator
Jul 6, 2009 at 7:37 PM

Problem was found in connectionstring to Access DB which provides values for drop-down lists. Please don't forget to populate DB according to your organization.

Latest code has been uploaded. Please refer to it as well.

Coordinator
Jul 6, 2009 at 8:01 PM

For those who have the previous code, please change your web.config and rename connectionstring fro ConStr to wateenConStr. It will work fine.

Aug 19, 2009 at 10:32 AM

thank you for your help - I now have it working.

a suggestion, if I may - perhaps edit the documentation to mention the changes necessary in the DB

 

btw. I am also having problems accessing the site with IE8 (Firefox works fine). this is the error that I get:

This error (HTTP 501 Not Implemented or HTTP 505 Version Not Supported) means that the website you are visiting doesn't currently have the ability to display the webpage, or support the HTTP version used to request the page.